WordPress update issue on Plesk Control Panel hosting

Most of us work with WordPress and while working we use the handy auto update feature in the admin panel to update the WordPress plug-ins and core. On Plesk control panel, sometimes it asks for FTP access details to write the files on the server. This could be quite irritating to input the same FTP details again and again.

One reason that I found causing this permission issue is – PHP running as Apache module. When new Plesk Account is created, PHP can be configured to run as Apache Module or FastCGI. The default is set to Apache Module and most of the time we do not need to change this. But if you are using WordPress on the Plesk control panel then remember to use PHP as FastCGI module to avoid above permissions issue. Now WordPress does not ask you FTP access details every time you want to update the WordPress from Admin panel.

Leave a Reply

Your email address will not be published. Required fields are marked *